Refused to set unsafe header

  • Trail Hacker 5 years, 1 month ago

    The ASP.NET control is generating lots of client side javascript errors. We’ve noticed it for a while, but it has never been a big problem for us. Recently, I dove into it and tried to see if it was something that we could fix. However, I see now that it is out of our hands. The problem is coming from the ASHX handler. Is there any chance to have these js errors fixed in a future release? Some of our users still actively use the ASP.NET control rather than the Silverlight control and it would be nice to clean these errors up.

    Below is a screenshot of the errors that I get simply by loading the tool into the browser. On page load, there are 30+ js errors… However, as the user begins to analyze data with the control, the errors add up very quickly resulting in +200 in only a few drag/drop operations.

    Thanks in advance.

    Attachments:
    You must be logged in to view attched files.
  • 107p
    SankalpS107p 5 years, 1 month ago

    trailHacker,

    Unfortunately I could not notice any errors when simply loading the pivotview control on the page. I used both Internet Explorer and Firefox to display the pivotview? Is this issue specific to your application or are you able to replicate it even in a new project? Could you please let me know the build of ActiveAnalysis which you are using at the moment? Any additional information provided to narrow down the issue would be appreciated.

    Regards,
    Sankalp

  • Trail Hacker 5 years, 1 month ago

    Sankalp,

    Sorry for the delay. Perhaps the problem is only in Google Chrome then. I’ve attached a sample that reproduces the problem on my machine using build 2.1.707.0.

    To reproduce the error, please follow these steps:

    1.) Extract the contents of the zip file to any directory.

    2.) Ensure that you have the nwind.mdb database on the c:\ drive.

    3.) Copy the custom.schema file to your c:\ drive (provided in the zip flie).

    4.) Double click on the *.sln file to open it in VS2010.

    5.) Set Google Chrome as your default browser for VS2010.

    — Right click on the Default.aspx page and choose “Browse with…”

    — Choose Google Chrome and click ‘Set as Default’

    — Click ‘Cancel’ (weird VS2010 dialog, I know) :)

    6.) Run the project by pressing [F5]

    7.) Show Google Chrome Developer tools (keys: [CTRL]+[SHIFT]+).

    NOTICE: There should be 30+ js errors.

    You will notice that if you drag and drop any field onto any shelf from the schema, your js error count climbs rapidly!!

    Hope this helps!

    Attachments:
    You must be logged in to view attched files.
  • churcyyang 5 years, 1 month ago

    Trail Hacker,

    I can reproduce it in Chrome. It is caused by PivotView. It seems that PivotView sets Referer and Content-Length in the every request header. In fact it is not safe setting.  So Chrome pops up this security error. I think we can consider to fix it in the future release.

    Regards,
    Churcy

  • Trail Hacker 5 years, 1 month ago

    That’s great. Thanks for the reply, Churcy!

  • fabioand2k 2 months, 1 week ago

    Hello,

    do you correct this bug ?

    i use 706 version, and become a lot of js errors in chrome.

    thanks

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.