Excel Export Does Not Use Defined Formats

  • Trail Hacker 6 years, 4 months ago

    Currently the export does not take the colors into consideration.

    Follow these steps to reproduce:

      Run to the Windows Viewer sample that ships with the setup.

      Click on ‘Data‘ -> ‘Connect to DataSource…’ menu option

      Select Unbound data connection

      Drop [Other Fields].[Book Title] on the RowShelf

      Drop [Measures].[Total Cost] and [Measures].[Advance] on the DataShelf

      Turn on Display Totals for Book Title

      Change the Header Cells background color to Red

      On the built in toolbar, click on Format (far right button)

      Choose Headers Format menu option…

      Uncheck the ‘Use defaults’ under Background color

      Click on the color box and change the color to Red

    Change the Data Cells background color to Green

      Follow above steps, but choose Data cells format and choose Green

    Change the Totals format to Purple

      Follow above steps, but choose Totals format to and choose Purple

    Click on ‘Export to Excel’ and save it to your desktop.

    Double click the file to open and notice that none of the colors were exported.

    My thought is that if the export is going to include colors, they should include the colors specified from the user.

    Bonus: It would be nice to have some options to configure additional options as well, similar to the way that DynamiCube handles it’s built in Excel Export (link).

    Attachments:
    You must be logged in to view attched files.
  • AashishB 6 years, 4 months ago

    Hello,

    I have added all our suggestions in Case 150062. Thank you for giving us the detailed steps.
    You would be notified if these features are implemented.

    Regards,
    Aashish

  • informatica3@seral-service.com 9 months, 3 weeks ago

    Hello,

    I have the same problem… Can I export to Excel with format now?

    All the managers of my company are requesting this export with format to me…

    Regards

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.